
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20190131161151
template: 
currentrequest: /apps/pbcs.dll/article?avis=TX&date=20190131&category=NEWS&lopenr=190139736&Ref=AR
currentrequestunmodified: /news/20190131/diocese-of-brownsville-releases-13-names-of-clergy-accused-of-abuse-of-minor
@templatetype: /apps/pbcs.dll/article?avis=TX&date=20190131&category=NEWS&lopenr=190139736&Ref=AR
@pagetype: article
app version: 2.0.264
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Valley Town Crier" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<!-- Meta Tags - Global Article6 guid: 7B4B526D-9EF3-4575-AE37-BBBEB33661E7-->
<meta name="description" content="Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor 
Staff Report 
Thirteen names dating back to 1965, the year the Diocese of Brownsville was founded, were released of those members of the clergy credibly accused of a minor. 
In a letter, Bishop Daniel E. Flores explained the release of the names are part of a commitment all bishops of Texas made September 2018. 
&ldquo;This is a painful day for the Church, yet one we must face,&rdquo; Flores wrote in his letter." />
<meta property="vf:unique_id" content="siteTX-pub3629-7B4B526D-9EF3-4575-AE37-BBBEB33661E7">
<meta property="fb:app_id" content="900641390023740"/>
<meta property="tout:article:id" content="art-7B4B526D-9EF3-4575-AE37-BBBEB33661E7-pub3629">
<meta property="bt:pubDate" content="20190131T15:52:22Z">
<meta property="bt:modDate" content="20190131T15:52:00Z">
<meta property="bt:author" content="Staff Report">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:image" content="https://www.Yourvalleyvoice.com/storyimage/TX/20190131/NEWS/190139736/AR/0/AR-190139736.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.Yourvalleyvoice.com/storyimage/TX/20190131/NEWS/190139736/AR/0/AR-190139736.jpg">
	<meta property="og:image:width" content="400">
	<meta property="og:image:height" content="400">
<meta name="twitter:site" content="@ValleyTownCrier">
<meta name="twitter:title" content="Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor">
<meta name="twitter:description" content="Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor 
Staff Report 
Thirteen names dating back to 1965, the year the Diocese of Brownsville was founded, were released of those members of the clergy credibly accused of a minor. 
In a letter, Bishop Daniel E. Flores explained the release of the names are part of a commitment all bishops of Texas made September 2018. 
&ldquo;This is a painful day for the Church, yet one we must face,&rdquo; Flores wrote in his letter.">
<meta property="og:title" content="Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor 
Staff Report 
Thirteen names dating back to 1965, the year the Diocese of" />
<meta name="author" content="Staff Report">
<link rel="canonical" href="https://www.Yourvalleyvoice.com/news/20190131/diocese-of-brownsville-releases-13-names-of-clergy-accused-of-abuse-of-minor"/>
<script type="text/javascript">var dfp_url = "7B4B526D-9EF3-4575-AE37-BBBEB33661E7";</script>
<link rel="amphtml" href="https://www.Yourvalleyvoice.com/news/20190131/diocese-of-brownsville-releases-13-names-of-clergy-accused-of-abuse-of-minor?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.Yourvalleyvoice.com/news/20190131/diocese-of-brownsville-releases-13-names-of-clergy-accused-of-abuse-of-minor"
	},
    "headline": "Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.Yourvalleyvoice.com/storyimage/TX/20190131/NEWS/190139736/AR/0/AR-190139736.jpg",
       	"height": 400,
       	"width": 400
    },
    "url": "https://www.Yourvalleyvoice.com/article/20190131/NEWS/190139736",
    "thumbnailUrl": "https://www.Yourvalleyvoice.com/apps/pbcsi.dll/bilde?Site=TX&Date=20190131&Category=NEWS&ArtNo=190139736&Ref=AR",
    "dateCreated": "20190131T21:52:22Z",
    "datePublished": "20190131T21:52:22Z",
    "dateModified": "20190131T21:52:00Z",
    "author": [{"@type":"Person","name":"Staff Report"}],
    "creator": "Staff Report",
    "publisher": {
       "@type": "Organization",
       "name": "Valley Town Crier",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.Yourvalleyvoice.com/Global/images/head/nameplate/yourvalleyvoice_logo.png"
       }
    },
    "articleSection": "News",
    "keywords": [""],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	}
  }
</script>

		<title> Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor - News - Valley Town Crier - McAllen, TX</title>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900">
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css">
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.264/default.min.css" type="text/css" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
    /*==== ARTICLE ======*/
    	.ad-300x150{
	    	width: 300px;
	    	max-height: 150px;
    	}
    	.adInject{
	    	clear:both;
    	}
    	.articleInjectAd{
	    	display: none;
    	}
    	.native-injected{
	    	height: 0px;
    	}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	/* Buzz widget */
    	#gh-slider-buzz > div > div > figure > a > div.image.unveil-loaded{
			min-height: 112px;
			box-shadow: 0px 0px 5px 0px rgba(50, 50, 50, 0.75);
			border-radius: 2px;
    	}
    	#gh-slider-buzz{
    		font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
    	}
    	#gh-slider-buzz h3 > span{
    		font-weight: bold;
			font-size: 14.4px;
			color:rgb(68, 68, 68);
			text-decoration-color:rgb(68, 68, 68);
			line-height: 16px;
    	}
    	#gh-slider-buzz h3 > span:hover{
			text-decoration: underline;
    	}
    	#gh-slider-buzz .dateline{
			font-size: 10px;
			color:rgb(153, 153, 153);
			text-decoration-color:rgb(153, 153, 153);
    	}
    	#gh-slider-buzz .gh-slider-caption h3{
	    	max-height: 500px;
    	}
    	#gh-slider-buzz div.nophoto > a > h3{
	    	margin-bottom: 5px;
    	}
    	#gh-slider-buzz div.nophoto{
	    	padding:0px;
    	}
    	#gh-slider-buzz span.summary{
	    	font-size: 11px;
		    max-height: 140px;
		    display: block;
		    line-height: 14px;
		    overflow: hidden;
    	}
    	#gh-slider-buzz .slick-slider,#buzz-widget-mobile .section-ribbon,#buzz-widget .section-ribbon{
	    	margin-bottom: 0px;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="//cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<!--[if lte IE 9]>
			<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="http://www.Yourvalleyvoice.com/news" target="_top">News</a></li><li><a href="http://www.Yourvalleyvoice.com/sports" target="_top">Sports</a></li><li><a href="https://www.Yourvalleyvoice.com/lifestyle" target="_top">Life</a></li><li><a href="http://www.Yourvalleyvoice.com/obituaries" target="_top">Obituaries</a></li><li><a href="http://valleytowncrier.tx.newsmemory.com/" target="_blank">E-Edition</a></li><li><a href="https://www.Yourvalleyvoice.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.Yourvalleyvoice.com/jobs" target="_blank">Jobs</a></li><li><a href="https://www.Yourvalleyvoice.com/homes" target="_blank">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/txmca" target="_blank">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<!-- JMETA MENU: SUBSCRIBE: count($items) = 0 -->
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.Yourvalleyvoice.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.Yourvalleyvoice.com">
							<img class="mainheadnameplate" src="https://www.Yourvalleyvoice.com/Global/images/head/nameplate/yourvalleyvoice_logo.png"  alt="Valley Town Crier" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<!-- JMETA MENU: SUBSCRIBE: count($items) = 0 -->
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.Yourvalleyvoice.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.Yourvalleyvoice.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>

				<div class="ad ad-billboard text-center" id="baseLeaderboard" data-size-mapping="baseLeaderboard"></div>
				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20190131155222">
	<div class="inner">
		<h1 class="headline">Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.Yourvalleyvoice.com/storyimage/TX/20190131/NEWS/190139736/AR/0/AR-190139736.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">Bishop Daniel E. Flores</div>
                <div class="credit"></div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					Staff Report
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Thursday</h3>
							<span class="article-meta-date">Jan&nbsp;31,&nbsp;2019&nbsp;at&nbsp;3:52&nbsp;PM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p>Diocese of Brownsville releases 13 names of clergy accused of abuse of a minor </p><p>
Staff Report </p><p>
Thirteen names dating back to 1965, the year the Diocese of Brownsville was founded, were released of those members of the clergy credibly accused of a minor. </p><p>
In a letter, Bishop Daniel E. Flores explained the release of the names are part of a commitment all bishops of Texas made September 2018. </p><p>
&ldquo;This is a painful day for the Church, yet one we must face,&rdquo; Flores wrote in his letter. &ldquo;As I said last October, an accurate accounting of the past is necessary for us to move forward with integrity.&rdquo;</p><p>
The letter continues explaining the release of names comes after an exhaustive review of the files to restore trust and healing. </p><p>
The communication of names is directed to the parishes of the diocese so that the Catholic faithful can be assured nothing is hidden in the files to the detriment of young people and that the protocols of the Dallas Charter of 2002 are being fully implemented. </p><p>
All the personnel files of priests, deacons and bishops were examined by a review team appointed by Flores comprised of seven lay women and one layman, all with experience in the education and protection of young people. The team was assisted in their work by the Chancellor and Victims Assistance Coordinator of the diocese. The review team was also given access to all 889 clergy files which included seven bishops, 711 priests and 171 deacons. </p><p>
All 13 cases found, with the exception of one, occurred before 2002. </p><p>
&ldquo;The Diocese of Brownsville has no credibly accused cleric in active ministry,&rdquo; Flores writes in his letter. &ldquo;I am grateful to the review team for their many hours of arduous and detailed work.&rdquo;</p><p>
Flores also notes that the review team did a great service to the Church at a great personal cost. Credibly accused does not necessarily mean guilty beyond doubt; it means there is evidence the abuse likely happened. </p><p>
The List </p><p>
A complete list and explanation was released on the diocese website as follows:</p><p>
As the Catholic faithful of the Rio Grande Valley, we share responsibility for the life and mission of the Church. We are committed to providing a safe environment for children.</p><p>
The Diocese of Brownsville, established in 1965, comprises 4,296 square miles in a four-county area, serving more than one million Catholics, or 85 percent of the total population. There are 72 parishes in the Diocese and 43 mission churches, currently served by 109 priests.</p><p>
As part of the ongoing work to protect children from sexual abuse and to promote healing and a restoration of trust in the Catholic Church, the bishops of the Catholic dioceses in Texas made a decision on Sept. 30, 2018 to release names of all clergy who have been credibly accused of sexually abusing a minor since 1950.</p><p>
A team of eight lay persons (seven women and one male) who hold positions of trust in the public and private sector, reviewed files of all bishops, priests, and deacons dating back to 1965 when the Diocese of Brownsville was founded. They, along with the assistance of the Chancellor and Victims Assistance Coordinator, reviewed each file to identify any credible allegation of clergy sexual abuse of a minor. Every record in our archives has been reviewed.</p><p>
Of the seven bishops, 711 priests and 171 deacons who have served in the Diocese of Brownsville since it was established in 1965, 14 clergy were identified (13 priests and one permanent deacon). None of the clergy listed are in active ministry in the Diocese of Brownsville.</p><p>
All the cases reported, with the exception of one, occurred before the year 2002. It is important to be aware that in several cases there was a gap between the time of the abuse and the time that the allegation was first reported.</p><p>
A &ldquo;credible allegation&rdquo; is one that, after review of reasonably available, relevant information in consultation with the Diocesan Review Board or other professionals, there is reason to believe is true. A credible allegation does not necessarily mean &ldquo;guilty beyond a reasonable doubt.&rdquo;</p><p>
Among the criteria used by the review team are the following: criminal conviction; indictment that was not defeated; legally mediated agreement; admission by cleric or religious; determination by Texas Department of Family and Protective Services; other adjudication, whether civil or canonical; Review Board recommendation; or prior determination by the bishop.</p><p>
The list that follows was provided by the review team, which spent more than 500 hours collectively looking at everything the Diocese has in its files, in an effort to provide healing to victims and an even safer environment for children. Should any subsequent credible allegations be reported, this list will be updated accordingly.</p><p>
List of Clergy with Credible Allegation of Sexual Abuse of a Minor&nbsp;before the Year 2002</p><p>
Humberto Acosta</p><p>
Born: February 7, 1949</p><p>
Ordained: May 30, 1974</p><p>
Left diocese in 1994. Allegation fully disclosed to receiving Military Ordinary in Venezuela.</p><p>
Assignments: St. Mary, Mother of the Church, Brownsville; St. Joseph Church, Edinburg; St. Anthony Church, Harlingen; Our Lady of Mercy Church, Mercedes; St. Margaret Mary Church, Pharr</p><p>
&nbsp;</p><p>
Lee DaCosta</p><p>
Born: June 29, 1937</p><p>
Ordained: April 23, 1973</p><p>
Retired in 2012. Faculties removed in 2019 after review team identified him as a priest who had a credible allegation of sexual abuse of a minor.</p><p>
Assignments: Sacred Heart Church, Edinburg; Sacred Heart Church, Escobares; St. Theresa Mission Church, Faysville; St. Anthony Church, Harlingen; Holy Family Church, La Grulla; St. Joseph the Worker Church, McAllen; Sacred Heart Church, McAllen; St. Joseph the Worker Mission Church, San Carlos; St. Anne Mission Church, San Manuel; Immaculate Conception Church, Rio Grande City; Our Lady, Queen of the Universe Church, San Benito; St. Joan of Arc Church, Weslaco; San Martin Porres Church, Weslaco; St. Pius X Church, Weslaco</p><p>
&nbsp;</p><p>
George B. Dyer, O.P.</p><p>
(deceased)</p><p>
Born: January 6, 1935</p><p>
Ordained: June 9, 1961 for the Dominican Friars</p><p>
He returned to the Dominican Friars in 1983.</p><p>
Died: 2013</p><p>
Assignments: St. Luke Church, Brownsville; Campus Ministry, Brownsville and Edinburg</p><p>
&nbsp;</p><p>
Armando Escobedo</p><p>
Born: June 8, 1936</p><p>
Ordained: June 6, 1964</p><p>
Removed from ministry in 2002.</p><p>
Assignments: Christ the King Church, Brownsville; St. Luke Church, Brownsville; St. Francis Xavier Cabrini Church, Laredo; Our Lady of Guadalupe Church, Lyford; Our Lady of Mercy Church, Mercedes; Our Lady of St. John of the Fields Church, Mission; St. Anthony Church, Raymondville</p><p>
&nbsp;</p><p>
Terrence Fowler</p><p>
Born: March 18, 1961</p><p>
Ordained: June 4, 1988</p><p>
Faculties removed in 1998. Laicization in process.</p><p>
Assignments: St. Joseph Church, Alamo; Christ the King Church, Brownsville; St. Luke Church, Brownsville; Immaculate Heart of Mary Church, Harlingen; Our Lady, Queen of the Universe Church, San Benito</p><p>
&nbsp;</p><p>
Frank Gomez</p><p>
(deceased)</p><p>
Born: October 28, 1928</p><p>
Ordained: May 27, 1961</p><p>
Died: May 20, 2014</p><p>
Faculties removed in 1994.</p><p>
Assignments: St. Joseph Church, Alamo; Our Lady of Guadalupe Church, Brownsville; St. Francis Xavier Cabrini Church, Laredo; St. Francis Xavier Church, La Feria; Sacred Heart Church, Mercedes; St. Theresa Church, San Benito; St. Mary Church, Santa Rosa; San Martin de Porres Church, Weslaco;</p><p>
&nbsp;</p><p>
James Jeffrey</p><p>
(deceased)</p><p>
Born: June 15, 1933</p><p>
Ordained: May 30, 1959 for the Diocese of Fargo, North Dakota</p><p>
Died: May 28, 2017</p><p>
A priest who was on loan to Diocese of Brownsville. Faculties removed in 1988 and he returned to home diocese.</p><p>
Assignments: Christ the King Church, Brownsville; St. Francis Xavier Church, La Feria</p><p>
&nbsp;</p><p>
Basil Onyia</p><p>
Born: May 22, 1966</p><p>
Ordained: July 13, 1996 for the Diocese of Aba in Nigeria</p><p>
On loan from the Diocese of Aba from 1999 to 2001.</p><p>
Removed from ministry in 2001. He fled the country after he was reported to civil authorities.</p><p>
Laicized: 2016</p><p>
Assignments: Immaculate Heart of Mary Church, Harlingen; Basilica of Our Lady of San Juan del Valle-National Shrine, San Juan</p><p>
&nbsp;</p><p>
Benedicto Ortiz</p><p>
(deceased)</p><p>
Born: September 1, 1930</p><p>
Ordained: April 13, 1957 for the Diocese of Areciba in Puerto Rico</p><p>
Incardinated to the Diocese of Brownsville: June 1, 1974</p><p>
Died: May 14, 2011</p><p>
Credible abuse report received in 2016.</p><p>
Assignments: Good Shepherd Church, Brownsville; Our Lady of Guadalupe Church, Brownsville; St. Anthony Church, Harlingen; Our Lady of Sorrows Church, McAllen; St. Anne, Mother of Mary Church, Pharr; Knapp Memorial Methodist Hospital, Weslaco; and HCA Rio Grande Regional Hospital, McAllen</p><p>
&nbsp;</p><p>
Salvador Rangel, MSF</p><p>
(deceased)</p><p>
Born: August 6, 1947</p><p>
Ordained: September 1, 1973</p><p>
Died: May 18, 2002</p><p>
Removed from ministry in 1977, returned to his religious community</p><p>
Assignments: St. Joseph Church, Donna; Our Lady of Assumption Church, Harlingen; Valley Baptist Medical Center, Harlingen</p><p>
&nbsp;</p><p>
Ivan M. Rovira</p><p>
Born: March 26, 1945</p><p>
Ordained: May 30, 1971 for the Diocese of Rockford</p><p>
Incardinated to Diocese of Brownsville: June 6, 1977</p><p>
Faculties removed in 2002.</p><p>
Assignments: Holy Family Church, Brownsville; St. Mary, Mother of the Church, Brownsville; Our Lady of Guadalupe Church, Brownsville; St. Joseph Church, Edinburg; Our Lady of Sorrows Church, McAllen; St. Joseph &amp; St. Peter Seminary, Mission; St.Pius X Church, Weslaco</p><p>
&nbsp;</p><p>
Salomon (David) Sandoval</p><p>
(deceased)</p><p>
Born: October 16, 1950</p><p>
Ordained: June 30, 1979</p><p>
Died: Date unknown</p><p>
Removed from ministry in the Diocese of Brownsville 1986. Allegation fully disclosed to receiving bishop in Ciudad Victoria.</p><p>
Assignments: Our Lady of Guadalupe Church, Brownsville; St. Joseph Church, Edinburg; Our Lady of the Holy Rosary Church, Mission; San Martin de Porres Church, Weslaco</p><p>
&nbsp;</p><p>
Marti G. Zuber</p><p>
Born: May 11, 1950</p><p>
Ordained: June 26, 1976</p><p>
Removed from ministry in 1993. Laicization in process.</p><p>
Assignments: St. Joseph Church, Edinburg; Campus Ministry, Edinburg; St. Anthony Church, Harlingen; St. Joseph Church the Worker, McAllen; Holy Spirit Church, McAllen; Immaculate Conception Church, McCook; Holy Spirit Church, Progreso; St. Anthony Church, Raymondville; San Martin de Porres Church, Weslaco;</p><p>
<br /><br /></p><p>
List of Clergy with Credible Allegation of Sexual Abuse of a Minor&nbsp;after the Year 2002</p><p>
Ronaldo Mitchell Chavez</p><p>
Born: August 13, 1973</p><p>
Ordained to permanent diaconate: December 18, 2010</p><p>
He was removed from active ministry in 2012. Pled guilty and sentenced to seven years in prison.</p><p>
Assignments: San Cristobal Magallanes &amp; Companions Church, Mission</p><p>
<br /><br /></p><p>
Terms Used</p><p>
Faculties&nbsp;&ndash; Permissions given by a bishop to a priest or deacon to perform certain ministerial acts.&nbsp; Faculties for both deacons and priests typically include the right to administer the sacraments of Baptism and Marriage, to preside at funerals, and to assist in other liturgies.&nbsp; Some faculties are reserved to priests and bishops, such as celebrating the Mass (Sacrament of the Eucharist), hearing confessions (Sacrament of Penance), anointing (Sacrament of Anointing the Sick).</p><p>
Incardinated&nbsp;&ndash; Term used when a given priest or deacon is received into the jurisdiction of a bishop.</p><p>
Removed from ministry&nbsp;&ndash; faculties or permissions to serve in ministry in or for the Diocese of Brownsville, or on behalf of a religious order, have been removed or suspended.&nbsp; Removal from ministry occurs before a laicization process begins (for ordained ministers) or before a process of expulsion from a religious order (for religious priests, brothers, or sisters).&nbsp; Laicization or expulsion are not automatically initiated after a man or woman is removed from ministry.&nbsp; A bishop or religious superior may determine that removal from ministry is warranted in a particular case but laicization or expulsion is not.</p><p>
Laicization&nbsp;&ndash; The return of a priest or deacon to the status of a lay person. A priest or deacon is not &ldquo;un-ordained&rdquo; through the process of laicization.&nbsp; Rather, the obligations of his ordination are dispensed, and the bishop&rsquo;s obligations to him are relieved.</p><p>
<br /><br /><br /></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<h2>Sign up for daily e-mails</h2>
					<a href="http://myprofile.yourvalleyvoice.com/">
						<button type="button" class="btn btn-subscribe">
							Sign up
						</button>
					</a>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://myprofile.yourvalleyvoice.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_VV" target="_top">My Profile</a></li><li><a href="https://www.Yourvalleyvoice.com/contact" target="_blank">Contact Us</a></li><li><a href="https://www.Yourvalleyvoice.com/submit" target="_blank">Online Forms</a></li></ul></div><div class="footer-col"><h4>Advertising<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://mediakit.gatehousemedia.com/Valley_TX/" target="_blank">Advertise With Us</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/txmca" target="_blank">Classifieds</a></li><li><a href="https://www.Yourvalleyvoice.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.Yourvalleyvoice.com/homes" target="_blank">Real Estate</a></li><li><a href="https://www.Yourvalleyvoice.com/jobs" target="_blank">Jobs</a></li><li><a href="https://www.Yourvalleyvoice.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Area Publications<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.laredosbargainbook.com" target="_blank">Laredo's Bargain Book</a></li><li><a href="http://www.adsack.com/classifieds" target="_blank">Ad Sack Classifieds</a></li><li><a href="http://www.valleybargainbook.com" target="_blank">Valley Bargain Book</a></li></ul></div><div class="footer-col"><h4>Community<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://www.mcallen.net" target="_blank">City of McAllen</a></li><li><a href="http://www.mcallenisd.org" target="_blank">McAllen ISD</a></li><li><a href="http://www.mcallenchamber.com" target="_blank">Chamber of Commerce</a></li><li><a href="http://www.mcallenlibrary.net" target="_blank">McAllen Library</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=TX&date=20190131&category=NEWS&lopenr=190139736&Ref=AR -->
			<div id="footer-main-copyright">
											<p id="footer-copyrightInfo">&copy; Copyright 2006-2019 <a href="http://www.gatehousemedia.com/about-us/" target="_blank">GateHouse Media, LLC.</a> All rights reserved&nbsp;&nbsp;&bull;&nbsp;&nbsp;GateHouse News</p>
							<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
							<br />Valley Town Crier  ~ 4500 N. 10th Street, Ste. 155, McAllen, TX 78504 ~ <a href="http://www.gatehousemedia.com/privacy-policy/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gatehousemedia.com/terms_of_use/" target="_blank">Terms Of Service</a></p>
							<script>document.getElementById('footer-main-copyright').getElementsByTagName('p')[1].innerHTML += '<a href="/ownership"><img id="footer-main-gh-logo" src="//cdn.gatehousemedia.com/gh-sites/global/images/logo/ghlogo_horizontal.png" alt="Gatehouse Media Logo"></a>'</script>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<br>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.Yourvalleyvoice.com" target="_top">Home</a></li><li><a href="http://www.Yourvalleyvoice.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"22075"><a href="http://www.Yourvalleyvoice.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"39513"><a href="https://www.Yourvalleyvoice.com/news/shareable" target="_top">Shareable</a></li></ul></li><li><a href="http://www.Yourvalleyvoice.com/sports" target="_top">Sports</a></li><li><a href="http://www.Yourvalleyvoice.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52635"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li></ul></li><li><a href="http://www.Yourvalleyvoice.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"22079"><a href="http://www.Yourvalleyvoice.com/opinion/columns" target="_top">Columns</a></li></ul></li><li><a href="http://www.Yourvalleyvoice.com/business-news" target="_top">Business</a></li><li><a href="http://www.Yourvalleyvoice.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="http://www.Yourvalleyvoice.com/photos" target="_top">Photos</a></li><li><a href="http://www.Yourvalleyvoice.com/submit" target="_top">Submit your news</a></li><li><a href="http://www.Yourvalleyvoice.com/section/?template=weather" target="_top">Weather</a></li><li><a href="http://www.Yourvalleyvoice.com/contests" target="_top">Contests</a></li><li><a href="http://www.Yourvalleyvoice.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.Yourvalleyvoice.com/section/promoted//?prx_adpz=2311" target="_top">From Our Advertisers</a></li><li><a href="https://www.Yourvalleyvoice.com/southern-kitchen" target="_top">Southern Kitchen</a></li><li><a href="http://www.printtoflip.com/149353/flipbook/?page=1" target="_top">Wedding Planner</a></li><li><a href="https://www.facebook.com/TheValleyTownCrier/photos/a.1950166901685672/1950166978352331/?type=3&theater" target="_top">VTC Rack Locations</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.yourvalleyvoice.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_VV" target="_top">My Profile</a></li><li><a href="http://valleytowncrier.tx.newsmemory.com/" target="_blank">E-Edition</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://mediakit.gatehousemedia.com/Valley_TX/" target="_blank">Advertise With Us</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/txmca" target="_blank">Classifieds</a></li><li><a href="https://www.Yourvalleyvoice.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.Yourvalleyvoice.com/jobs" target="_blank">Jobs</a></li><li><a href="https://www.Yourvalleyvoice.com/homes" target="_blank">Homes</a></li><li><a href="https://www.Yourvalleyvoice.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://yourvalleyvoice.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:info@valleytowncrier.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/terms_of_use/">Terms of Use</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/privacy-policy/">Privacy Policy</a>
		</li>		
		<li>
			<a href="http://www.gatehousemedia.com/our-markets/">GateHouse Media Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.Yourvalleyvoice.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/TheValleyTownCrier""
								target="_blank"
								title="Valley Town Crier Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="http://www.twitter.com/ValleyTownCrier""
								target="_blank"
								title="Valley Town Crier Twitter">
								<i class="fa fa-fw fa-twitter"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="Valley Town Crier RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.Yourvalleyvoice.com/contact"
								title="Contact Valley Town Crier">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.264/app.min.js"></script>
		<script async src="//cdn.gatehousemedia.com/assets/2.0.264/confiant.min.js"></script>
<script>!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
		<script>
		function __gh__init() {
			var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		__gh__init();
		</script>
		<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1"></script>

		
<!--currenttimestamp: 2019-01-31&nbsp;17:12:02-->
	<script type="text/javascript">
//<![CDATA[
(function() {
var _analytics_scr = document.createElement('script');
_analytics_scr.type = 'text/javascript'; _analytics_scr.async = true; _analytics_scr.src = '/_Incapsula_Resource?SWJIYLWA=719d34d31c8e3a6e6fffd425f7e032f3&ns=2&cb=1619469607';
var _analytics_elem = document.getElementsByTagName('script')[0]; _analytics_elem.parentNode.insertBefore(_analytics_scr, _analytics_elem);
})();
// ]]>
</script></body>
</html>